jet pump problem

My well pump apparently lost its prime tonight, I noticed air coming out the faucets before it quit entirely. I have a (part) artesian well, and there is a side pipe/overflow (whatever you want to call it)from the well that always flows into the swamp out back, all year long. I shut that off to build pressure into the house so i could deal with the pump in the AM, but water never came. So I went out, took the fill cap off the pump and turned to grab a water jug. When I turned back water was flowing out so I had my prime, I capped it and turned it on and its working for now.
questions:
What should I look for as a cause of the problem? This never happened before and I assume it aint a good thing! I did look and listen for leaks but didnt notice any.
About that overflow pipe-I reopened it but does that need to be open? Why?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Losing prime in a jet pump could be from air getting into the pump housing somehow, which means a leak. The first thing to do is check all the joints for any leakage before you get too far into it, it might be a simple matter of tightening or replacing a clamp or reinstalling a threaded connection with some teflon tape.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I think I found the problem in the Air Volume control, which appears to be leaking (water out, air in).
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.