irrigation system water

I recently moved into a house that has in inground irrigation system for the lawn. I am trying to "open the system" (ie turn it on for the season). This will be the first time I've done this since living here (I live in the North East, so the system was blown out last fall. I seem to be having a problem getting water to enter the system. In my basement right after the water meter I have a branch that connects to PVC pipe (about right where the valve box is outside). Right before this there's a ball valve. I turned the valve to the ON position but nothing seems to be happening. I expected to hear a WHOOSH or something. I didn't think too much of it and headed out to try out my zones. I can from the control computer run tests on each zone, but no water is coming out. I can hear each valve in the valve box open as the test goes, but no water. I've put all the zone valves in the ON position, but that doesn't matter if there's no water. I've double and triple checked that there's no other valve in between the meter and the irrigation system. There's also a spiget right near the zone valves, this also does not get water. Could the ball valve be stuck closed? The handle moves okay, but could the inside be stuck? Could a clog do this? Is there a step I'm missing? Thanks in advance...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I'd check the valves at the backflow protector. There are generally two used while blowing out the system. might have been left closed Bob

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.