Intermittent problem with Goodman GMP075-3

I am a home owner and have a Goodman GMP075-3 (Serial # 9901611013) with a strange intermittent problem. The call for heat is made from the thermostat, the ID motor starts, after a short period of time the burners fire up. Now intermittently, it sounds like the burners are struggling to stay lit (sounds stupid but sort of a whoosh, whoosh, whoosh sound). After a few seconds the gas valve clicks and shuts off the burners. With the ID fan still running this process will repeat until the burners stay lit, usually only one more time. The LED on the controller board has never flashed, just stays solid red.
I have called a professional who has been out three times. First time he replaced the flame sensor, second time he replaced the pressure switch. The last time he came out he cleaned the burners and the entire unit. None of this helped.
Does anyone have any suggestions?
Thanks,
Ed
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ed wrote:

There is at least a chance that this is a supply (pressure) problem.
Jim
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Jim,
I have 2 of these units in my home, only one is acting up, plus a gas water heater, but good idea.
Thanks!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Cracked heat exchanger, wrong burners, weak inducer, etc Bubba
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bubba,
I forgot to mention that the inducer was replaced a few months ago.
Ed
Bubba wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Not to sound snide, but I'd call another pro out. Try to get a recommendation from Goodman, or the local Goodman factory dealer. I haven't had to work on too many Goodman's myself, my luck I guess. Has the tech taken any pressure reading on the gas valve, checked heat exchanger or inducer assembly?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The tech did check the pressure at the gas valve. It was 5 and he adjusted it to 3.5. The inducer was replaced a couple of months ago, I don't know about the heat exchanger, I'll ask on the next visit.
Ed
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.