Hotpoint fridge always running


Hi, I have an approx. 10 or so year old Hotpoint refrigerator (freezer on top), model # according to sticker inside freezer compartment "Hotpoint No Frost CTX18GA 18.2 cubic foot refrigerator-freezer". I acquired it from a relative's estate about a year and a half ago, and noticed that to keep the refrigerator compartment under 40 degrees F, that the temperature dial must be set pretty close to maximum, set to 8. I have the freezer set to C (goes from A to E), and the freezer works great at that setting.
The problem is the compressor is running about 70% of the time. I remember timing the on-off cycle, something like 45 minutes on, then 17 minutes off, then 41 minutes on, and 21 minutes off, etc. Is this normal? Also there will be sometimes a couple of mild thuds a few seconds after the compressor stops. If not normal, what should I try? I have an older fridge in the basement, the kind you have to manually defrost, and it seems that one is only running about 25% of the time. Thanks much.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I would be checking the timer and the freon level.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Also make sure the coils are clean.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Not normal. Probably dirty condensor, or low on freon. Or both.
--

Christopher A. Young
You can\'t shout down a troll.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.