Help with Honda Riding Mower

I have a Honda Harmony 1011 Mower - it is a very nice 30 inch riding mower with rear bagger.
It starts up first time - every time - if I give it a squirt of starting fluid. Then it runs forever. If you restart it hot - it starts fine without the starter fluid. But when it is cold or has not been started in an hour - you must squirt some starting fluid into the carb.
It just started doing this - before it started fine every time - hot or cold.
I have changed the oil. I have cleaned the air cleaner. I removed the spark plug - it is clean and dry.
I repeat - it starts first crank every time - with a shot of starter fluid into the carb.
Any ideas on a fix?
Harry
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Harry wrote:

I would hope so... :(

Sounds like weak spark/old plug or dirty carb or choke not fully closing. Does this have a "prime" bulb or fuel pump or is it gravity fed?
The problem is the mixture isn't right or the spark isn't hot enough so that it isn't firing off when cold. Fix whatever is weak/out of adjustment there and it'll start.
Of course, depending on how old it is, it could be somewhat more serious but if the plug isn't showing signs of fouling, it probably just needs good tuning/tlc...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
sounds like choke adjustment.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Replace the gasket between the carb and the side of the engine.
--

Christopher A. Young
Do good work.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.