Heat Pump odd sound

When ever the heat pump goes into and out of the defrost cycle the evaporator inside makes a kind of horn or as i seen someone else say a moose call sound. Seems to be working ok. But i had a problem were they replaced the dryer and the service man said the sound was normal to here, IS IT??? Cant remember if i heard the sound last year or not. Plus it has an on demand defrost but seems to be defrosting every 90 min. temp out side around 28, should an on demand defrost that offten. That im sure it did not do last year, but also had that defrost board replaced with an updated version. The old on demand has a wire that checked the outdoor tempture on it, the new on demand board does not. Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Mon, 03 Dec 2007 23:12:09 -0500, snipped-for-privacy@looking.now wrote:

The sounds is all wrong. It should be making the sound of a red-crested whiperwhil. The defrost should happen every 94 minutes. Try a new thermostat. Bubba
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Male or female?

I heard 00:94:22

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.