Hayward pool heater

I have an odd problem that just started this season. The fan turns on that purges the combustion chamber then a few seconds later the flame is lit, the problem is sometime later if I put my hand over the exhaust its blowing cold air like the flame went out but it doesn't relight itself. I have to turn the knob to a lower temp then put it back to where I had it and then it works fine for a while then may or may not go out. I don't know if its the wind that is blowing out the flame or something else? Does anyone have experience with these heaters?
Any help would be appreciated, Rich
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
sounds like you're not getting enough gas to the heater to keep the burner going. Your gasline may need to be on the high pressure side of the regulator if you have a long distance to the heater. That's something for the gas man to check out.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the reply Dan. Is this something the gas company would do as a check and correct the pressure or is it pay as you go?
Thanks for heading me in the right direction, Rich

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.