Hayward comfortzone inground pool heater - pilot won't light

The pilot won't light on our Hayward comfort zone pool heater. It has a switch that is supposed to do it, but nothing happens when we use it. Is it safe to try to light it with a match? Any other suggestions? Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If you can get a match near the flame, sure.
I find the first time I turn it on each spring it takes a while to get it to light the first time. Make sure all the pipes are open, and turn it on, let it run for a while. If it doesn't light turn it off for a while then back on. And so on.
I've found the heaters to be far from trouble free. In the second year I replaced the pressure sensor and the manifold (leaking).
In the fourth year I had to replace the control board (it wouldn't light). The only way I could diagnose it was I found one of the components hanging lose from the board.
I think I'm starting the 7th season now. Last year the fan wouldn't run so I opened it up and the fan was extremely rusted. I did manage to get it turning and haven't replaced it yet but I'm pretty sure I will have to this year.
Oops, more than you wanted to know...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.