hayward 1 HP pool pump problem

My impreller was initially clogged with junk - got that freed but now my pump/strainer housing will stay filled up with water drains down to about halfway and then impeller stops and pump just keeps on going. Any suggestions?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Sounds like you need a new impeller. If the pump is going and the impeller isn't, then that means it's not connected to the shaft, and most likely the plastic impeller is broken. It's probably a good idea to also replace the seal while it's apart.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I think what he meant to say here is the impeller stops, but the motor keeps going. I'm a little curious as to how he knows the impeller isn't turning. The ones I've seen, the impeller is inside the pump housing and you can't visually tell if it's turning. If you're just assuming the impeller isn't moving, maybe it is and it's possible there is more blockage from debris in the piping somewhere? Otherwise, the impeller could be stripped, in which case agree with TH above. You can get a new impeller and seals for a reasonable price.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.