GE portable A/C problem (apn08/apn10/aph10)

Have GE model apn08/apn10/aph10 portable air conditioner. When starting up, it's supposed to display the room temperature. The temperature it displays is much less than the actual room temperature, usually in the high 50s; thus, the compressor never turns on because the unit thinks it's colder than the thermostat setting (minimum setting is 64). Does anyone have any experience fixing these units? If so, which part is the part that is likely to have failed? According to the parts list here: http://www.myapstore.com/Omega/Dispatcher?REQUEST ¬CESSORY&mainFrameUrl=POPUP&modelNumber=APH10AAG1&title=Repair%20Parts, it seems likely to part drawing reference number 3,4, or 5. Which monitors the temperature? Unit is 14 months old, in-house warranty would no longer cover this issue. Any ideas?
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@yahoo.com wrote:

http://www.myapstore.com/Omega/Dispatcher?REQUEST ¬CESSORY&mainFrameUrl=POPUP&modelNumber=APH10AAG1&title=Repair%20Parts,
link no good errors every time
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@aol.com wrote:

Hmmm...http://products.geappliances.com/ApplProducts/Dispatcher?REQUEST=SPECPAGE&SKU=APN08AA&SITEID ̃R&CHANNEL=CH0004&TABID=3 will get you there (click on parts and accessories)
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.