Gas weed eater

I got a Homelite Zipstart trimmer. Won't run. Has spark. Went through the carb, and all ports and jets seem okay. Going to disassemble again. The carb gaskets look good, but should I just go get a new set? What's the most common reason these things stop running? I'm guessing carb.
Steve
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I don't have this brand but as a guess....spark plug clean? Fuel filter clean? Muffler clean?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I guessing "made by Homelite"
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 9/5/2012 8:19 PM, Ed Pawlowski wrote:

most accurate answer.
www.stihlusa.com
--
Steve Barker
remove the "not" from my address to email
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Wednesday, September 5, 2012 12:06:17 PM UTC-4, Steve B wrote:

Put a little gas/oil mix in a spray bottle. Take off the air filter and spray some in the carb. Pull the cord. If it fires up for a few seconds then it's not getting gas.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.