Evcon gas furnace

My Evcon gas furnace is not working again. The unit is only 4 years old. Last year I replace the blower motor. Now it won't fire up. The red test light isn't blinking indicating there is not a problem. It is trying to do something when asked to turn on. It make a low electric buzz sound but goes no further. The ignitor looks fine. All wiring is secure. Any ideas on the most likley problem? Thanks. Adam.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Is the gas turned on?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Model numbers sure help, since York bought out Coleman-Evcon about 10 years ago... Is it a downflow, counterflow, or MP furnace?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It's a Coleman-Evcon BGU10016A Forced Air Furnace. Last year when they unit was acting up and I replace the blower motor, it would start up. The red light was blinking several times indicating a problem with the Pressure Switch. I knocked it a couple of times and wa-la. It worked problem free until now. This is the first time I'm asking the unit for heat in 7 months. Odly, the A/C side of the unit will not work now. It just makes a low hum as though the blower is trying to spool up but can't. I changed the capacitor but no help. Thanks for the help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.