Dewalt DC980 torque control doesn't work

I just got a DC980. On medium and high speed the torque control works just fine. On low, where you need it because that is screwdriver country, it doesn't work. I noticed that complaint on Amazon, but figured the person didn't know how to use it. Maybe we both don't know how to use it, or maybe it doesn't work. Anyone with experience here?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
toller wrote:

On my DeWalt, the torque setting only work on the medium speed and not on the high or low. It may not be defective, it may be the way it was designed. Not sure of the reason, but perhaps the clutch is not built to work under the high torque of low speed.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

That is when it is needed the most. I'd return it for a replacement or other brand.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Edwin Pawlowski wrote:

On the contrary, I use the torque clutch when working with wood, plaster, plastic, etc which hardly require the full torque of slow spped. I have found little need for the clutch on the slow speed when I am trying to bust a nut free, or drive a very long screw. The speed ranges overlap a bit for this purpose, and as such the clutch works well when I need it.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.