Chronomite instant-flow water heater not working

Hi, I got a Chronomite SR-15L 277V instant-flow water heater in our office restroom. The water flow has always been slow through his water heater, and recently it has slowed so much that the heater is now not turning on. I disconnected the flex pipe from the faucet and confirmed that the slowness is not due to the faucet. So it is either the input valve or the water heater itself that is causing this slowness.
I disconnected the flex pipe at the input valve and then reconnected it. The flow was better for a while and the heater turned on. But after a while, the flow slows again and now the heater is not turning on anymore.
The flex pipe from the input valve to the water heater is a 20" 1/2" IPS, 3/8" comp.
Here is the spec to the Chronomite heater: http://www.chronomite.com/Instant-Flow-SR/SR-Models-Applications.html
Any clue?
The other restroom next to this restroom has exactly the same setup and it works perfectly there.
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Frodo from the shire is the one to ask. Hes the expert on water heaters.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Did you check if there were screens either at the input valve or the ends of the flex pipe, and that they were clear?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.