John Deere L120

I have a L120 riding lawn mower that is 2 1/2 years old. It doesn't move forward or in reverse very fast. I replaced the drive belt and that seemed to help some, but it's not right. It almost seems like something is slipping inside and it gets worse the longer it runs. Almost like the oil in it gets warm and allows something to slip.
Has anyone ever replaces the fluid in one of these hydrostatic transmissions?
Thank you.
Swede
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Yes - in my Wheelhorse 520H (20 HP Onan). Surprisingly my owner's manual just called for regular 30 W oil. But you better check JD for yours. Mine also has an oil filter for the hydro. Got my replacement at NAPA. If your oil level is up to where it is supposed to be, I would check the shift linkage.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
there is a kit with bellows and fluid avaiable from dealer
http://www.minibite.com/america/malone.htm
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Lots of mumbo-jumbo at the JD site but I don't see your kit listed.
"Hy-Gard has an ISO 32 Viscosity Grade. Hy-Gard viscosity places it between ISO 46 and 68 grades. Hy-Gard may be used in many applications specifying either of these grades. It has the same performance specifications as Hy-Gard and can be used as a replacement for Hy-Gard in cold weather."
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.