echo string trimmer fuel hose is 'riddled like swiss cheese' & won't run (pic posted)

my echo string trimmer won't run for longer than ONE SECOND, no matter -what- I do. one (of the three) fuel lines is riddled with numerous pinholes - the pinholes only "squirt out sideways everywhere" when the primer bulb is pushed. might those tiny holes ALONE cause it to be unable to run longer than a second? not at all clear to me which fuel line serves what purpose on this machine. "otherwise all conditions are good to go" on the dern thing. baffling.
I posted a good clear captioned pic of this at
http://machines.awardspace.com/echo_hose_questions /
are these tiny black fuel lines 'off the roll' stuff at mower shops? or is this a 'proprietary deal' type thing?
thanks guys,
toolie
-- for replies by e-mail please remove the weirdstuff from my address before you click 'send'. thanks :-) --
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

You can use 'generic' fuel line of the correct size, but it must be approved for fuel (or it will dissolve or start a fire).
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
i saw the fuel line kits at home depot yesterday.
http://www.minibite.com/america/malone.htm
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.