Trane air handler cycling on and off

In South Florida and I have an 11 year old Trane XLI14, air handler model # 4TEE3F49A1000AB. Starting today, the air handler motor kicks on, ramps up to speed, and then after 2 to 15 seconds, shuts completely off - (no ramp down as usual). Within 2 seconds, it repeats.
I removed the thermostat and connected red and green wires. Same result. Next I removed the side panel near the blower motor. AH is in the attic an d it was hot, so I did not stay long. But the contactors were working and the blower moved freely by hand. I'm assuming it is some kind of thermal o verload or the time delay relay. I let it rest for about 1 hour, and then it ran fine. But I suspect it is going to do it again soon. Any help woul d be appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
lborne wrote:

Checked starting/run caps.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks. Will check those tonight when it is cooler. Unit worked OK overnight.
On second thought, it seems to be cycling too quickly to be a thermal issue. I also forgot to mention that the compressor is working fine and Freon is good.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 11/11/2015 6:37 AM, lborne wrote:

Sure it's Freon? Might be Isotron, or Genetron, or Forane.
--
.
Christopher A. Young
learn more about Jesus
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.