Problem with AC comressor fast cycling

Hello,
Having some trouble with a 25 ton AC system. After a few minutes of running the compressor starts cycling very quickly - on and off every 3 seconds or so. When it's doing this the supply pressure guage show a fairly steady 130 psi. The suction pressure guage rises to about 40 psi when the compressor is running and drops to about 20 psi when stopped. It's not HP cut out, the condenser is getting plenty of cooling water. It's not motor overload either. What's going on? Expansion valve not opening properly?
Any suggestions appreciated...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
LPCO

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thanks for all the help and concern. Don't worry, I've switched to the other system for now. An LPCO is on the way. I'm also interested in how things work so when the compressor is doing funny things my curiosity is piqued. What would cause the suction pressure to drop so quickly? Refrigerant can't be getting round the circuit quickly enough to keep the suction pressure up. This is why I think the expansion valve is blocked or not opening properly. Or possibly an undercharged system but it has been working perfectly up till now and this problem occurred suddenly.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.