hvac

My goodman furnace/ air has been having unusual delays, on days where I switch between heat and air. The thermostat seems ok, at least I can hear the relay switch, sometime waiting a couple minutes. I switched off the power to the furnace a couple times, but don't have enough info on my actions. All know, it didn't used to do this. I can only guess it's the board
Greg
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I am not familiar with the system that you have However it is my opinion that it supposed to have delay when you switch from one to other, and if did not have one to start with, than it was wrong to began with.
face=Verdana>...</FONT></DIV><FONT face=Verdana>&gt; My goodman furnace/ air has been having unusual delays, on days where I<BR>&gt; switch between heat and air. The thermostat seems ok, at least I can hear<BR>&gt; the relay switch, sometime waiting a couple minutes. I switched off the<BR>&gt; power to the furnace a couple times, but don't have enough info on my<BR>&gt; actions. All know, it didn't used to do this. I can only guess it's the<BR>&gt; board <BR>&gt; <BR>&gt; Greg</FONT></BODY></HTML>
------=
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thanks. I am going to check things out. Right now, it seems clear, to switch modes, I have to turn off the electricity, wait about 5 minutes, and it will switch on. It seems forever or never, when I just play with the thermostat. I can hear the clicks from the stat. I'm going to look at board, understand now there are error codes to be read, possibly. Understand the board is mostly for furnace. I got variable speed fan, slow start.
Greg
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Looked at board. Took batteries out of thermostat. Ac came on. Strange. Batteries a little low, replaced. Did not see any low batt warning. Testing.
Greg
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Well, seems to be working. I would have never guessed. But I did decide to change batteries. Maybe also reset thermostat.
Greg
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.