comfortmaker RPJ II, ingiter not getting power/signal, WHY?

I have a comfortmaker rpj II that doesn't heat up, blower turns on runs and kick off. I tested for power there is no power or no signal being sent to the igniter. I replaced the igniter and the heat sensor to make sure they were working, they are both good. The red light blinks 6 times. The code says that 115 volt ac power reversed/improper ground.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Saturday, October 26, 2013 6:44:02 PM UTC-4, andrew wrote:

some of these controllers use the chassis ground as part of the flame sensor circuit.
If the power connection is not exactly correct with regard to the hot neutral and ground, it can confuse the controller. Make sure the hot is the black wire, neutral is the white wire, and ground it really ground.
Mark
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@yahoo.com wrote:

Hi, Really funny, disregarding trouble code OP replaced HSI, flame sensor? Where is his logic?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Saturday, October 26, 2013 6:44:02 PM UTC-4, andrew wrote:

Did you check the ground, hot, and neutral to make sure they were connected correctly? Also check the other end of the wire at the breaker.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 10/26/2013 5:44 PM, andrew wrote:

Why are you asking us, when you already have the answer?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.