A Second Opinion...AC Not Blowing.

I have a split Carrier unit (inside gas furnace/blower & outside compressor). The inside blower moter (2-speed) will not start as normal. I have elimated the thermostat (jumpered at the unit), it also appears the capacitor and motor are OK (I placed jumper from COM to both HI and LO connectors and the motor runs fine. That leaves the control board. The transformer seems OK (24V to 120V), but the relays do not seem to pull in. Any other steps I can take? Is it worth trying to troubleshoot down to the board level, or just replace? Any idea where I can acquire a board if needed? Thanks!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I'm sorry.

I guess its broke

ok.......
I hate it when that happens...

yes
no
yes
yes
your welcome
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If you've got some electronic skills, you can troubleshoot within the board. Many people don't.
I usually call my wholesale parts house for replacement boards.
--

Christopher A. Young
You can\'t shout down a troll.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Sat, 22 Jul 2006 13:07:50 GMT, "Stormin Mormon"

Once again, this leaves Stormy out.

Im sure they really love you, Stormy. Cant diagnose a single thing. Just order up a box full of parts and keep replacing until you find the right part to make it work again. Bubba
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.