Sprinkler stopped working..

My sprinkler system did a strange thing. Sprinkler draws from a lake, stopped working about 1 month ago, (house is cira '85), I replaced the intake pipe, the screen head, and the back flow valve. Pipe extends out about 20' and floats (attached to a duck float). All went well and the sprinkler was working fine for about 3 weeks. Then I notices a slow reduction in the amount of water coming out, unitl finally no more. I check all new connections, all is fine. Pulled the pump apart, impeller looks good, a couple of gaskets warped but nothing terrible. (intake head has screens to prevent unwanted items entering system)
Any ideas???
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
algae. you got something getting thru the screening. Ingrid
snipped-for-privacy@alpha-rx.com (Kurtctio) wrote:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ List Manager: Puregold Goldfish List http://puregold.aquaria.net / www.drsolo.com Solve the problem, dont waste energy finding who's to blame ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Unfortunately, I receive no money, gifts, discounts or other compensation for all the damn work I do, nor for any of the endorsements or recommendations I make.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.