Poulan blower starts only by priming?

After starting and running great, one day the Poulan 432 PRO blower would not start. After pulling the cord about a dozen times, I removed the spark plug. It was dry, it should have been wet with the gasoline/oil mix. This indicates it's not getting fuel. So I removed the air cleaner and primed it. It ran until the primer fuel ran out. I did this several times and then all of a sudden, it kept running. I did all the leaf blowing I wanted to do, shut it down, and immediately tried to start it. Nope, didn't even fire. Took off the air cleaner, did the primer thing, and eventually it ran. What the hell could be causing this?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

not
plug. It

it's
ran
did
to
Had about the same thing happen to me while using my Echo Trimmer.
I finally emptied out the old gas/oil mix and replaced it with a fresh mixed batch of gas/oil. Problem solved.
The gas/oil mix I had been using had been mixed properly and was not very old, but the unit would not run on it after a few uses.
Shepherd
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check for a clogged fuel filter? Sometimes they are on the end of the pickup line in the fuel tank. Use fresh mix also.

would
indicates
I
primer
mixed
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.