No eggplants???

Any ideas why I don't have any eggplants growing on my eggplant plants?
The plants look very healthy and there are plenty of buds but they never start eggplants.
I have the plants in two sections of the garden in groups of 4 plants each group. Close by are zucks and cucumbers that are doing wonderfully themselves. The ground is ph nuetral with a base of clay and sandy loam with peat and sterilized manure added in to top 8 to 12 inches over the past 10 years. Region 6b.
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Him said:

Have the blossoms opened or have they dropped before opening?
Any chance something is nipping the blossoms off? I've had problems some years with young starlings nipping off eggplant flowers. Some years they concentrated on squash buds. (They definitely run through a trial-and-error period as they learn fend for themselves, and it's not always pretty.)
What's the weather been like locally? We have set some record lows here, which have not been eggplant-friendly. (Good thing I had some fruit set during a warmer spell.)
--
Pat in Plymouth MI ('someplace.net' is comcast)

Any technology distinguishable from magic is insufficiently advanced.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.