gas ignition problems


I have a faily new range gas cooker
Might as well tell how it went wrong first .....
I put a potato in the oven but when I went to gt it out it rolled backwards into the flames at the back. No problem, turned off the gas, and got the potato out.
Now when I light the oven it sparks, then lights and a few seconds later it flames properly.
Trouble is that a few seconmds after that. the elctonoc spark startsagain even though the gas is fully on
Any ideas please (other than dont cook potatoes)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Have a look for a small tube that should sit in base of the flame. It has probably been knocked out of the way. It is a type of thermocouple and needs to get hot to tell the spark unit the flame is lit.
Adam
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Have a look for a small tube that should sit in base of the flame. It has probably been knocked out of the way. It is a type of thermocouple and needs to get hot to tell the spark unit the flame is lit.
Adam
Hi Adam cant thank you enough, all fixed now.
back to the spuds
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.