domestic electric problem


Hi I've lost all lighting, upstairs and downstairs, except the hall. I've replaced the 5A fuse wire which had blown but still no lighting and it hasn't sice blew the fuse. There's electric going through the fuse and there appears to be no loose or broken connections in the fusebox. Any ideas please? By the way, the house has been altered by the previous owner and some of the electrical work is very shoddy. The house is about 30 years old and as far as I know hasn't had a rewire, so my other question is how much is a typical rewire to get done, for a 3 bed semi? TIA Phil
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I take it upsatirs and down are both on the 5amp fuse then ? Turn ALL power off check the wireing in the hall that works it might be a short or a cable loose there that feeds the others (even though it works), if not maybe the next in line, downstairs hall maybe..... quotes depend on area and amount of work to be done difficult for a quote, get 3 quotes from local recomended electricians.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Thanks for that. I just wiggled the bulb in the hall and everything works now. Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It would be best to turn it all off and check the connections, you obviously have a problem, if it blew the fuse, could be a short, a loose cable, damaged connector or cable etc, could be a fire risk etc if you dont sort it out. If all looks ok just tighten the screws and check cables, if your still unsure get a electrician to check it out.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Will do. Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

perhaps there is a passthru in that rose? and its loose. And liable to short/make fire
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

There was a loose connection. It's tight again now and everythings ok. Thanks for your help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.