Central heating problem. Please help !!!!


I have a Ideal Icos boiler in my home which is used for hot water & the central heating which incidentally is a unfloor heating system. Since the past couple of days the boiler does not fire up for the central heating. The UFH system looks to work perfectly fine & there is a proper water circulation and all usual trouble shooting techniques with UFH does not reveal any issue. Assuming the UFH system is working fine, I am struggling to find out why the boiler does not fire when the Central heating demands it.
Hot water is available whenever required and boiler only fires up for it.
Could someone please help?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Since no one else is answering who may be more knowledgeable here is my 2 pennies worth. Central heating will not work if the pump is faulty. There may be a fault in the wiring or control unit which controls the pump. If you cannot check these items yourself a good electrician will be able to help Blair
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
what type of system do you have? do you get a switched supply to the boiler... if not maybe the valve not sending the system a control voltage. Check valve type and drop me a line
pete
pushps wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.