AEG dishwasher won't continue cycle after draining


AEG 6040 dishwasher - drains water fine but just carries on pumping and cycle won't continue. Seems to think water not all gone. Had this problem once before, a couple of weeks ago, after main wash - persuaded to continue by pouring water in, shaking machine etc. Now stuck again before final rinse, same problem. Tries again pouring water in - pumps out fine, but has not helped this time. Is there some kind of water level sensor, perhaps built into the pump? Live in a hard water area - can limescale cause this? Should we descale machine (although now difficult if inoperable)? Thanks for any insights.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Source of problem now identified - some water is collecting in the tray at the base of the machine, triggering the flood protection float switch. I removed left side panel and tipped machine sideways to drain water as suggested elsewhere for this problem. Machine now functioning normally. Am now running through a cycle with panels removed to try and find primary cause, i.e. any obvious leak.
"x" <j> wrote in message

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

HomeOwnersHub.com is a website for homeowners and building and maintenance pros. It is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.